Frustration and Progress

This is going to be a short one. I want to treat this website better because it’s something I own and control, BECAUSE IT IS MY NAME! BECAUSE I CANNOT HAVE ANOTHER IN MY LIFE! *cough* Sorry, that line pops into my head from time to time.

Anyway, I’ve been trying desperately to close out some projects. The one I’ve been putting off, and for good reason, is updating the storage in my computer. I run my longterm storage in a hardware RAID 1 configuration. You don’t have to worry too much what that means, but it’s to provide data redundancy. I use my motherboard onboard RAID controller to manage it, which is probably a little too trusting on my part. I originally had 2 4TB drives, but ran out of space. I don’t really like to delete things. I had to upgrade.

Storage is cheap, and getting cheaper, but I still am not made of money, so I bought two 10TB external usb drives on sale. You can remove the internal drives from these enclosures in what commonly referred to as “shucking.” Why buy external drives if you are just going to destroy the enclosure? For some reason the drive manufactures will often make those cheaper than buying the bare drives. Well, I did that, and it turned out to not be that bad.

The hard part came when I tried to install them and they wouldn’t power up. Turn out there is a 3.3V pin on the power connector, and if that has a voltage on that pin, it disables the drive. The workaround is either tape off that pin or use a Molex to SATA adapter because those don’t carry 3.3V. That seemed better so I did that.

Then my RAID controller was acting up so I had to backup my stuff to an external drive before proceeding for extra precaution. I use a utility called rsync, it works really well, but it’s a Linux utility. The new Linux subsystem on Windows works great with it, albeit a little convoluted.

Finally, it all worked! I had my new 10TB drives with all my stuff back. It took like 5 days, but I got it.

That was until this morning. I was updating stuff, and one of my motherboard utilities was updating a chipset driver and it blue screened my system and now won’t boot. One step forward, two steps back. This is why I cautiously backup though. Nothing can be easy, can it?

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.